My build of the simple terminal from suckless.org.
Vous ne pouvez pas sélectionner plus de 25 sujets Les noms de sujets doivent commencer par une lettre ou un nombre, peuvent contenir des tirets ('-') et peuvent comporter jusqu'à 35 caractères.
 
 
 
 
 

19 lignes
559 B

  1. #!/usr/bin/make -f
  2. # Needed for the st.1 VERSION fixup in override_dh_installman.
  3. include /usr/share/dpkg/pkg-info.mk
  4. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  5. %:
  6. dh $@
  7. override_dh_auto_install:
  8. # The upstream install target runs tic(1), and we don't want to. We could patch
  9. # the command away, but it is simpler to install the couple of files we actually
  10. # want using debhelper. Let's disable dh_auto_install.
  11. override_dh_installman:
  12. dh_installman
  13. sed -i "s/VERSION/$(DEB_VERSION_UPSTREAM)/g" $(CURDIR)/debian/stterm/usr/share/man/man1/st.1