My build of dwm
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 

36 lines
1.5 KiB

  1. Description: Modified command and rules to use Debian specific tools
  2. By default dwm uses uxterm as terminal emulator
  3. this is modified now to use x-terminal-emulator
  4. command instead.
  5. .
  6. Also patch modifies class rules to use Iceweasel instead of Firefox
  7. as that is the replacement for Firefox on Debian system.
  8. Author: Vasudev Kamath <kamathvasudev@gmail.com>
  9. Forwarded: not-needed
  10. Last-Update: 2016-03-25
  11. --- a/config.def.h 2016-03-26 22:54:02.066831758 +0100
  12. +++ b/config.def.h 2016-03-26 22:54:20.974134262 +0100
  13. @@ -26,7 +26,7 @@
  14. */
  15. /* class instance title tags mask isfloating monitor */
  16. { "Gimp", NULL, NULL, 0, 1, -1 },
  17. - { "Firefox", NULL, NULL, 1 << 8, 0, -1 },
  18. + { "Iceweasel", NULL, NULL, 1 << 8, 0, -1 },
  19. };
  20. /* layout(s) */
  21. @@ -55,7 +55,7 @@
  22. /* commands */
  23. static char dmenumon[2] = "0"; /* component of dmenucmd, manipulated in spawn() */
  24. static const char *dmenucmd[] = { "dmenu_run", "-m", dmenumon, "-fn", dmenufont, "-nb", normbgcolor, "-nf", normfgcolor, "-sb", selbgcolor, "-sf", selfgcolor, NULL };
  25. -static const char *termcmd[] = { "st", NULL };
  26. +static const char *termcmd[] = { "x-terminal-emulator", NULL };
  27. static Key keys[] = {
  28. /* modifier key function argument */
  29. @@ -110,4 +110,3 @@
  30. { ClkTagBar, MODKEY, Button1, tag, {0} },
  31. { ClkTagBar, MODKEY, Button3, toggletag, {0} },
  32. };
  33. -